Upgrade Laravel 5.7 to Laravel 5.8

The Laravel 5.8 Shift automates the upgrade of your Laravel application from Laravel 5.7 to Laravel 5.8. Using the Laravel 5.8 Shift to automatically upgrade your Laravel application has an estimated time savings of 1 hour.

It's important to remember Laravel 5.8 is the latest version. As such, both Laravel and the Laravel 5.8 Shift are under active development.

Requirements

  • A Laravel application running Laravel 5.7.0+.
  • A server running PHP 7.1.3+.

Core Upgrades

The Laravel 5.8 Shift automates many of the upgrades listed in the Laravel Upgrade Guide, including:

  • Translating the TTL for Cache methods from minutes to seconds.
  • Removing unnecessary deleted_at date cast from SoftDeletes Models.
  • Detecting deferred Service Providers.
  • Upgrading core Middleware to their Laravel 5.8 versions.
  • Moving Markdown assets to their new folder structure.
  • Detecting backward incompatibilities within your application code.
  • Converting Blade syntax.
  • Updating composer.json for Laravel 5.8.

Additional Upgrades

In addition to the Core Upgrades, the Laravel 5.8 Shift performs additional upgrade beyond those listed in the Laravel Upgrade Guide, including:

  • Adopting the PSR-2 coding style to match the coding style in Laravel.
  • Modernizing PHP syntax, such as the short array syntax.
  • Converting string based class references to ::class references.
  • Converting deprecated string and array helper functions to their respective Arr and Str methods.
  • Updating core config files to their Laravel 5.8 versions.

Manual Upgrades

There are some upgrades the Laravel 5.8 Shift can not perform automatically. When Shift detects these it adds a detailed comment on the Pull Request to help guide the manual upgrade.

Still have questions? Message @laravelshift on Twitter or email shift@laravelshift.com.